Bienvenue, Invité
Merci de vous identifier ou de vous inscrire.    Mot de passe perdu?

Debian 7 Wheezy et Magento ! PHP 5.4
(1 lecteur(s)) (1) Invité(s)
Aller en basPage: 1234
SUJET:

Debian 7 Wheezy et Magento ! PHP 5.4

#65050
Boutik Circus
Nicolas Trossat
Platinum Boarder
Messages: 672
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin boutik-circus Boutik Circus nicolas.trossat@boutik-circus.fr Lieu: Var Date anniversaire: 18/04

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 21  
Oui de meilleurs perfs pour PHP 5.4, notamment sur les traitements massifs de données, mais je n'ai pas fait de benchmark
 
L'administrateur a désactivé l'accès public en écriture.
#65252
Tartanpion
Platinum Boarder
Messages: 452
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 4  
Bonjour

Voila le message que j’obtiens avec php 5.4.17 et Debian 7
Code :


Whoops, it looks like you have an invalid PHP version.

Magento supports PHP 5.2.0 or newer. Find out how to install Magento using PHP-CGI as a work-around.



cela peut venir d'un problème avec Apache ?
Code :

'; exit; } /** * Error reporting */ error_reporting(E_ALL | E_STRICT); /** * Compilation includes configuration file */ define('MAGENTO_ROOT', getcwd()); $compilerConfig = MAGENTO_ROOT . '/includes/config.php'; if (file_exists($compilerConfig)) { include $compilerConfig; } $mageFilename = MAGENTO_ROOT . '/app/Mage.php'; $maintenanceFile = 'maintenance.flag'; if (!file_exists($mageFilename)) { if (is_dir('downloader')) { header("Location: downloader"); } else { echo $mageFilename." was not found"; } exit; } if (file_exists($maintenanceFile)) { include_once dirname(__FILE__) . '/errors/503.php'; exit; } require_once $mageFilename; #Varien_Profiler::enable(); if (isset($_SERVER['MAGE_IS_DEVELOPER_MODE'])) { Mage::setIsDeveloperMode(true); } #ini_set('display_errors', 1); umask(0); /* Store or website code */ $mageRunCode = isset($_SERVER['MAGE_RUN_CODE']) ? $_SERVER['MAGE_RUN_CODE'] : ''; /* Run store or run website */ $mageRunType = isset($_SERVER['MAGE_RUN_TYPE']) ? $_SERVER['MAGE_RUN_TYPE'] : 'store'; Mage::run($mageRunCode, $mageRunType); 
 
Dernière édition: 10/07/13 à  10:26 Par Tartanpion.
L'administrateur a désactivé l'accès public en écriture.
#65254
Boutik Circus
Nicolas Trossat
Platinum Boarder
Messages: 672
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin boutik-circus Boutik Circus nicolas.trossat@boutik-circus.fr Lieu: Var Date anniversaire: 18/04

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 21  
Jamais vu cette erreur...
Visiblement il a un soucis pour lire la version de PHP. Il faudrait voir ou est fait le contrôle pour comprendre ce qui ne va pas.
 
L'administrateur a désactivé l'accès public en écriture.
#65294
Tartanpion
Platinum Boarder
Messages: 452
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 4  
Bon pour le moment cela à l'air de fonctionner
 
L'administrateur a désactivé l'accès public en écriture.
#65295
Tartanpion
Platinum Boarder
Messages: 452
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 4  
Bonjour

Est-ce vraiment intéressant d'utiliser FCGId en lieu et place de mod_php pour Apache ?

(Je n'ai pas remarqué de meilleures performances !)

Cdt
 
Dernière édition: 13/07/13 à  10:20 Par Tartanpion.
L'administrateur a désactivé l'accès public en écriture.
#65296
togefran
Gold Boarder
Messages: 161
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 4  
trop de facteurs en jeu pour répondre de façon générale.
 
L'administrateur a désactivé l'accès public en écriture.
#65336
Tartanpion
Platinum Boarder
Messages: 452
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 4  
Boutik Circus écrit:
On utilise Debian 7 et PHP 5.4 sur des magento de 1.1.8 (si si ;) ) à 1.7 sans soucis. Il peut y avoir 2-3 correctifs a apporter (ZEND_PDF de mémoire) mais pas de problème bloquant. Et quitte a passer sur php-5.4, profitez-en pour passer sur MariaDB également (full compatible).

En effet, l'impression des PDF ne fonctionne pas (page blanche)..

Je recherche des infos sur ce sujet afin de régler le souci, sii qq1 a rencontré ce souci avec php 5.4
 
L'administrateur a désactivé l'accès public en écriture.
#65337
Tartanpion
Platinum Boarder
Messages: 452
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Debian 7 Wheezy et Magento ! PHP 5.4

Il y a 5 Années
Karma: 4  
Il semblerait qu(il faille modifier le fichier :lib/Zend/Pdf/FileParserDataSource.php

The issue was fixed in the Zend Framework 1.11.12.
 
L'administrateur a désactivé l'accès public en écriture.
Revenir en hautPage: 1234
Modérateur: Gabriiiel, ILOA, zuiko