Bienvenue, Invité
Merci de vous identifier ou de vous inscrire.    Mot de passe perdu?

Passer du serveur de développement au serveur de production
(1 lecteur(s)) (1) Invité(s)
Aller en basPage: 1...678910111213
SUJET:

Passer du serveur de développement au serveur de production

**
#27937
sornette
Senior Boarder
Messages: 58
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 7 Mois
Karma: 0  
Pour la petite histoire, j'ai tout repris du début et ça fonctionne!
 
L'administrateur a désactivé l'accès public en écriture.
#28922
mikael
Fresh Boarder
Messages: 1
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 7 Mois
Karma: 0  
API ERROR
Bonjour,

J'ai installé un problème de passage chez nbs.
J'ai suivi le tuto.
Le paiement atos ne fonctionne pas.
J'ai pourtant modifié le pathfile.
Il fait appel au chemin absolu de l'ancien hébergeur lorsque je clique sur le retour boutique.

quelqu'un à une idée?



Error reading certificate file (/homez.97/jeudemai/www/magento/lib/atos/certif.fr.043024640500020)


Trace:
#0 /var/www/barassocies/boutiquerugby/prod/app/code/local/Mage/Atos/Model/Api/Response.php(93): Mage::throwException('doResponse('202033383160302...', Array)
#2 /var/www/barassocies/boutiquerugby/prod/app/code/core/Mage/Core/Controller/Varien/Action.php(376): Mage_Atos_StandardController->normalAction()
#3 /var/www/barassocies/boutiquerugby/prod/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(248): Mage_Core_Controller_Varien_Action->dispatch('normal')
#4 /var/www/barassocies/boutiquerugby/prod/app/code/core/Mage/Core/Controller/Varien/Front.php(158): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 /var/www/barassocies/boutiquerugby/prod/app/Mage.php(459): Mage_Core_Controller_Varien_Front->dispatch()
#6 /var/www/barassocies/boutiquerugby/prod/index.php(65): Mage::run()
#7 {main}
 
L'administrateur a désactivé l'accès public en écriture.
#31631
nathanael.attali
Avancer lentement mais surement
Gold Boarder
Messages: 174
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
MIster-optic: Lunettes de Soleil nathanael.attali@gmail.com nathanael.attali@gmail.com

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 5 Mois
Karma: 2  
Regarde du coté du firewall si l'adresse de retour ou d'envoi n'est pas bloqué par le firewall de l'hebergeur ;)
 
Magento C'est de La dynamite !
L'administrateur a désactivé l'accès public en écriture.
#32693
huno
Fresh Boarder
Messages: 11
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 4 Mois
Karma: 0  
Bonjour,

Je désespère totalement, ça fait 2jours que j'essay tout ce que je trouve pour importer ma db sur mon server de production et rien ne marche, exporter avec la sauvegarde interne de magento, exporter depuis phpmyadmin en décochant les clé étrangère, bigdump... rien ne marche, j'arrive toujours où à l'erreur "Error Submission Form" ou alors j'ai le site (avec pas le bon theme) et quand je suis dans l'admin aucune page ne marche et me revois aussi dans Error submission Form.

Avec bigdump si j'essay d'uploader une base de donné sauvegardé de phpmyadmin, il va jusqu'au bout sans rien dire, mais le site me donne directement l'error submission.

Si j'essay d'uploader la sauvegarde faite depuis le pannel d'admin de magento je me tape cette erreur:

Code :

Error at the line 371: ) ENGINE=InnoDB AUTO_INCREMENT=8 DEFAULT CHARSET=utf8;

Query: CREATE TABLE `catalog_category_entity_varchar` (
`value_id` int(11) NOT NULL AUTO_INCREMENT,
`entity_type_id` smallint(5) unsigned NOT NULL DEFAULT '0',
`attribute_id` smallint(5) unsigned NOT NULL DEFAULT '0',
`store_id` smallint(5) unsigned NOT NULL DEFAULT '0',
`entity_id` int(10) unsigned NOT NULL DEFAULT '0',
`value` varchar(255) NOT NULL DEFAULT '',
PRIMARY KEY (`value_id`),
UNIQUE KEY `IDX_BASE` (`entity_type_id`,`entity_id`,`attribute_id`,`store_id`) USING BTREE,
KEY `FK_ATTRIBUTE_VARCHAR_ENTITY` (`entity_id`),
KEY `FK_CATALOG_CATEGORY_ENTITY_VARCHAR_ATTRIBUTE` (`attribute_id`),
KEY `FK_CATALOG_CATEGORY_ENTITY_VARCHAR_STORE` (`store_id`)
) ENGINE=InnoDB AUTO_INCREMENT=8 DEFAULT CHARSET=utf8;

MySQL: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'USING BTREE, KEY `FK_ATTRIBUTE_VARCHAR_ENTITY` (`entity_id`), KEY `FK_CATALO' at line 9



Si quelqu'un à 5 minute pour m'aider ce serait super !!

Merci
 
L'administrateur a désactivé l'accès public en écriture.
#32700
abi
Senior Boarder
Messages: 41
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 4 Mois
Karma: 4  
Bonjour,

J'avais eu le même souci et cela provenait de versions différentes de MYSQL sur les 2 serveurs qui réagissaient différemment.
La solution que j'avais trouvé à l'époque sur un blog mysql était d'enlever du fichier dump la mention 'USING BTREE'. Et ca avait bien marché.

Tu peux toujours essayer pour voir.
Bon courage.
 
L'administrateur a désactivé l'accès public en écriture.
#32727
huno
Fresh Boarder
Messages: 11
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 4 Mois
Karma: 0  
oui en effet la base s'upload bien avec cette technique

par contre après que l'upload se soit terminé, je me rend sur le site et toujours cette eureur. J'a reçus ce mail d'erreur suite à l'upload

Code :

URL:***
IP Address: ***
Time: 2010-06-05 00:48:15 GMT
Error:
Recoverable Error: Argument 1 passed to Mage_Core_Model_Store::setWebsite() must be an instance of Mage_Core_Model_Website, null given, called in ***/app/code/core/Mage/Core/Model/App.php on line 554 and defined  in ***/app/code/core/Mage/Core/Model/Store.php on line 283

Trace:
#0 ***/app/code/core/Mage/Core/Model/Store.php(283): mageCoreErrorHandler(4096, 'Argument 1 pass...', '/home/vhosts/sa...', 283, Array)
#1 ***/app/code/core/Mage/Core/Model/App.php(554): Mage_Core_Model_Store->setWebsite(NULL)
#2 ***/app/code/core/Mage/Core/Model/App.php(393): Mage_Core_Model_App->_initStores()
#3 ***/app/code/core/Mage/Core/Model/App.php(299): Mage_Core_Model_App->_initCurrentStore('', 'store')
#4 ***/app/Mage.php(596): Mage_Core_Model_App->run(Array)
#5 ***/index.php(78): Mage::run('', 'store')
#6 {main}


(j'ai remplacé le chemin par des *** ;))

J'y comprend RIEN, ça vous parle ?
 
Dernière édition: 04/06/10 à  19:52 Par huno.
L'administrateur a désactivé l'accès public en écriture.
#32728
jplorge
Junior Boarder
Messages: 21
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur
Sexe: Masculin jplorge Lieu: Belgium Date anniversaire: 19/09

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 4 Mois
Karma: 0  
huno écrit:
UNIQUE KEY `IDX_BASE` (`entity_type_id`,`entity_id`,`attribute_id`,`store_id`) USING BTREE,

ici la solution
www.eliasinteractive.com/blog/magento-da...-fk_catalo-at-line-9

pas très clair à cause de <p style="text-align: left; "> placé juste avant.
donc:
UNIQUE KEY `IDX_BASE` (`entity_type_id`,`entity_id`,`attribute_id`,`store_id`) USING BTREE,

and replaced it with this:
UNIQUE KEY `IDX_BASE` USING BTREE (`entity_type_id`,`entity_id`,`attribute_id`,`store_id`),

Bonne chance j'ai mis aussi 2 jours il y à 2 mois
 
L'administrateur a désactivé l'accès public en écriture.
#32752
huno
Fresh Boarder
Messages: 11
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Passer du serveur de développement au serveur de production

Il y a 8 Années, 4 Mois
Karma: 0  
Merci pour vos réponse, using btree résoud le premier problème, mais après c'est encore d'autre erreur qui apparaissent... magento à encore un gros chemin à faire...
J'abandonne le passage du local a la prod, j'installe un site tout neuf sur mon server et je vais tout refaire online, je crois que ça me prendra moins de temps que de trituré la db et le php dans tous les sens.
 
L'administrateur a désactivé l'accès public en écriture.
Revenir en hautPage: 1...678910111213
Modérateur: Gabriiiel, ILOA, zuiko