Bienvenue, Invité
Merci de vous identifier ou de vous inscrire.    Mot de passe perdu?

SSL et éléments non secure
(1 lecteur(s)) (1) Invité(s)
Aller en basPage: 1
SUJET:

SSL et éléments non secure

#70069
fiatminimisetpatria
Fresh Boarder
Messages: 5
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

SSL et éléments non secure

Il y a 4 Années, 1 Mois
Karma: 0  
Bonjour les amis,
Dans un acte d'allégeance à Google Inc., j'ai décidé de passer un site Magento en SSL sur tout le site.
Mais voilà, ce site maintenant sécurisé a l'impertinence de présenter des éléments non sécurisés dans le source et le navigateur renvoie donc un message d'alerte d'utilisation d'éléments non chiffrés.
Vous conviendrez qu'il est assez gênant de générer des messages effrayants pour l'utilisateur alors qu'on cherche à le rassurer...

Cela arrive par exemple lorsqu'on clique sur l'ajout au panier.
Je suppose que le problème vient des boutons avec un code js associé qui contient une URL qui n'aurait pas été modifiée en httpS.
Avant de bourriner avec un include pour tous les .js et qui irait réécrire les url, je souhaiterais savoir s'il existe une option qui m'aurait échappé ?
Bien sûr j'ai passé les champs du BO "Use Secure URLs" en ssl pour le BO et FO. Il n'y a pas d'erreur de certificat (url affichées en vert dans le navigateur et pas d'alerte tant qu'on ne clique pas sur un bouton avec js)

En espérant l'aide d'une bonne âme.

Julien.
 
L'administrateur a désactivé l'accès public en écriture.
#70071
devlab
Fresh Boarder
Messages: 2
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:SSL et éléments non secure

Il y a 4 Années, 1 Mois
Karma: 0  
avez vous achetez un certificat ssl pour le nom de domaine associé au site?
 
L'administrateur a désactivé l'accès public en écriture.
#70094
fiatminimisetpatria
Fresh Boarder
Messages: 5
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:SSL et éléments non secure

Il y a 4 Années, 1 Mois
Karma: 0  
Mince pas de réponse.
Après avoir installé un certificat SSL, personne n'a observé un message depuis le navigateur du type :
"Bien que cette page soit chiffrée, les informations saisies vont être transmises en clair (sans chiffrement) et pourraient être lues lors de leur acheminement.
Voulez-vous vraiment transmettre ces informations ?"

Ça doit être courant comme problème et je ne vois d'option pour fixer ce défaut sans coder.

Sinon je posterai la solution si je trouve...

Julien.

Ps: le certificat SSL est correctement installé.
 
L'administrateur a désactivé l'accès public en écriture.
Revenir en hautPage: 1
Modérateur: Gabriiiel, ILOA, zuiko