Bienvenue, Invité
Merci de vous identifier ou de vous inscrire.    Mot de passe perdu?

Problème One Page Checkout et redirection vers la banque
(1 lecteur(s)) (1) Invité(s)
Aller en basPage: 1
SUJET:

Problème One Page Checkout et redirection vers la banque

#52280
easypara
Expert Boarder
Messages: 136
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Problème One Page Checkout et redirection vers la banque

Il y a 7 Années, 3 Mois
Karma: 1  
Bonjour à tous,

Je rencontre actuellement un bug lors de la passation de commandes avec quelques clients.

Lorsque ils finalisent leur commande avec paiement par CB (bouton place order par défaut), au lieu d'être redirigé vers le site de la banque, ils sont directement redirigés vers la page "votre panier est vide".

Les utilisateurs concernés utilisent IE (toutes versions confondues) et voient leur problème réglé en changeant de navigateur.

En regardant dans les logs d'erreurs, je n'ai pas d'erreur inscrite et dans les logs d'accès je vois bien que ca bloque...

Ex de log d'accès :

Code :

"POST /checkout/onepage/saveOrder/ HTTP/1.0" 200 443 "http://www.easyparapharmacie.com/checkout/onepage/index/"
"GET /atos/standard/redirect/ HTTP/1.0" 200 1356 "http://www.easyparapharmacie.com/checkout/onepage/index/"



ou même parfois :

Code :

"POST /checkout/onepage/saveOrder/ HTTP/1.0" 200 443 "http://www.easyparapharmacie.com/checkout/onepage/" 
"GET /checkout/cart/ HTTP/1.0" 200 22365 "http://www.easyparapharmacie.com/checkout/onepage/" 
"GET /checkout/onepage/ HTTP/1.0" 302 417 "http://www.easyparapharmacie.com/checkout/cart/" 
"GET /checkout/cart/ HTTP/1.0" 200 22365 "http://www.easyparapharmacie.com/checkout/cart/" 



Alors que je devrais avoir quelque chose comme ceci :

Code :

"POST /checkout/onepage/saveOrder/ HTTP/1.0" 200 443 "http://www.easyparapharmacie.com/checkout/onepage/index/"
"GET /atos/standard/redirect/ HTTP/1.0" 200 1356 "http://www.easyparapharmacie.com/checkout/onepage/index/"
"POST /atos/standard/normal/ HTTP/1.0" 302 428 "-"
"GET /checkout/onepage/success/ HTTP/1.0" 200 23198 "-"



Je suis sur un Magento 1.4.1.0 et j'utilise le module de paiement atos/sips (mis à jour avec la version de quadra, mais le problème persiste).

Le patch suivant a été appliqué sur le module de paiement : blackotine.tumblr.com/post/1693438636/ip...on-atos-pour-magento

Si une personne a eu ce problème où a une piste à me suggérer, je suis preneur d'infos ;)
 
L'administrateur a désactivé l'accès public en écriture.
#53464
dkmax
Fresh Boarder
Messages: 19
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Problème One Page Checkout et redirection vers la banque

Il y a 7 Années, 1 Mois
Karma: 0  
Bonjour,

J'ai un problème assez semblable.
A savoir les clients sous IE ne sont pas redirigés vers le site de banque une fois la commande finalisée.

Si quelqu'un a rencontré le meme probleme et trouvé une solution...

D'avance merci,
Max

Magento version 1.4.2 - Atos / Quadra : 2
 
L'administrateur a désactivé l'accès public en écriture.
#53466
easypara
Expert Boarder
Messages: 136
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Problème One Page Checkout et redirection vers la banque

Il y a 7 Années, 1 Mois
Karma: 1  
N'ayant pas eu de réponses, voyant les commandes perdues et la hiérarchie commençant à me mettre la pression , j'ai fait intervenir la société Miuraconseil.

Ils m'ont solutionné le problème en 30 minutes d'intervention ;)
Apparemment, il s'agisait d'un bug connu de la communauté lié au javascipt (j'avoue ne pas être tombé sur un poste en parlant où alors je l'ai zapé ).
J'en ai profité pour faire un petit audit de code.
Le rapport qualité/prix de leurs prestation est plus que raisonable !
 
L'administrateur a désactivé l'accès public en écriture.
#61130
webjojo
Fresh Boarder
Messages: 1
graphgraph
Personne n'est hors ligne Cliquez ici pour voir le profil de cet utilisateur

Re:Problème One Page Checkout et redirection vers la banque

Il y a 6 Années
Karma: 0  
Bonjour,

J'ai exactement le même problème sur mon site, pourrais-tu nous dire comment tu as résolu ton problème javascript lié du bouton "Passer la commande"?

Cordialement,
 
L'administrateur a désactivé l'accès public en écriture.
Revenir en hautPage: 1
Modérateur: Gabriiiel, ILOA, zuiko